hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashutosh Chauhan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-2715) Upgrade Thrift dependency to 0.9.0
Date Wed, 31 Oct 2012 02:11:11 GMT

    [ https://issues.apache.org/jira/browse/HIVE-2715?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13487455#comment-13487455
] 

Ashutosh Chauhan commented on HIVE-2715:
----------------------------------------

Sure. Not a problem.
                
> Upgrade Thrift dependency to 0.9.0
> ----------------------------------
>
>                 Key: HIVE-2715
>                 URL: https://issues.apache.org/jira/browse/HIVE-2715
>             Project: Hive
>          Issue Type: Bug
>          Components: Metastore
>    Affects Versions: 0.8.0, 0.9.0
>            Reporter: Mithun Radhakrishnan
>            Assignee: Ashutosh Chauhan
>         Attachments: hive-2715.patch
>
>
> I work on HCatalog (0.2). Recently, we ran into HCat_server running out of memory every
few days, and it boiled down to a bug in thrift, (THRIFT-1468, recently fixed).
> HCat-0.2-branch depends on Hive-0.8, which in turn depends on thrift-0.5.0. (The bug
also exists on 0.7.0.)
> May I please enquire if Hive can't depend on a more current version of thrift? (Does
it break the metastore?) I'm afraid I'm not privy to the reasoning behind Hive's dependency
on a slightly dated thrift-lib. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message