hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amit Sangroya <>
Subject Hive 0.9.0 with hadoop 0.20.2 (fair scheduler mode)
Date Thu, 27 Sep 2012 08:56:50 GMT
Hello everyone,

I am experiencing that Hive v-0.9.0 works with hadoop 0.20.0 only in
default scheduling mode. But when I try to use the "Fair" scheduler using
this configuration, I see that map reduce do not progress and hive log
shows "table not found" exception. I am using MySql database.

This is very strange behavior. I tried to fix if there is any issue in
hive, or if there is anything to configure in hadoop.

I also tried few other combinations:

   1. For me, Hive v-0.9.0 works with hadoop 0.20.0 in default scheduling
   2. I can also observe that Hive v-0.7.0 works with hadoop 0.20.0 even
   with Fair scheduler and default scheduler.
   3. Hive v-0.9.0 works with hadoop 1.0.0 in both default  and fair
   scheduling mode.

Did anyone tried to run Hive v-0.9.0 works with hadoop 0.20.0 with
fair scheduler. Is there any extra setting/parameter for this.

Thanks in advance,

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message