hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Namit Jain (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
Date Wed, 12 Sep 2012 04:18:07 GMT

     [ https://issues.apache.org/jira/browse/HIVE-3339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Namit Jain updated HIVE-3339:
-----------------------------

    Status: Open  (was: Patch Available)

comments on phabricator
                
> Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-3339
>                 URL: https://issues.apache.org/jira/browse/HIVE-3339
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Namit Jain
>            Assignee: Zhenxiao Luo
>            Priority: Minor
>         Attachments: HIVE-3339.1.patch.txt
>
>
> This should be done for code cleanup.
> Instead of the rule being:
> SEL%
> It should say SelectOperator.getName()%
> It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message