hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Namit Jain (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-3339) Change the rules in SemanticAnalyzer to use Operator.getName() instead of hardcoded names
Date Tue, 07 Aug 2012 06:31:03 GMT
Namit Jain created HIVE-3339:
--------------------------------

             Summary: Change the rules in SemanticAnalyzer to use Operator.getName() instead
of hardcoded names
                 Key: HIVE-3339
                 URL: https://issues.apache.org/jira/browse/HIVE-3339
             Project: Hive
          Issue Type: Bug
            Reporter: Namit Jain
            Priority: Minor


This should be done for code cleanup.

Instead of the rule being:

SEL%

It should say SelectOperator.getName()%

It would make the rules more readable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message