hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-3278) Create wrappers around Thrift Metastore objects for improved readability
Date Tue, 31 Jul 2012 02:41:34 GMT

    [ https://issues.apache.org/jira/browse/HIVE-3278?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13425476#comment-13425476
] 

Carl Steinbach commented on HIVE-3278:
--------------------------------------

The 'M' prefix is is already spoken for. We use it as the prefix for the Modeled objects that
Datanucleus persists to the metastore, e.g. o.a.h.hive.metastore.model.MTable. I suppose we
could prefix the stuff in ql.metadata with an 'H', but before we do that I'd first like to
move that code over to the metastore package and do some other cleanup work. Also, we should
eventually wrap the HiveMetaStoreClient library with an improved version that uses the H*
types instead of the raw Thrift types.
                
> Create wrappers around Thrift Metastore objects for improved readability
> ------------------------------------------------------------------------
>
>                 Key: HIVE-3278
>                 URL: https://issues.apache.org/jira/browse/HIVE-3278
>             Project: Hive
>          Issue Type: Improvement
>          Components: Metastore
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message