hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Travis Crawford (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-3278) Create wrappers around Thrift Metastore objects for improved readability
Date Tue, 31 Jul 2012 02:02:34 GMT

    [ https://issues.apache.org/jira/browse/HIVE-3278?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13425466#comment-13425466
] 

Travis Crawford commented on HIVE-3278:
---------------------------------------

Totally agree with the sentiment. What are your thoughts on renaming {{org.apache.hadoop.hive.ql.metadata}}
classes something like {{MTable}} (prefixed with M or some other letter) and using them in
the code whenever possible. This would distinguish the two sets of classes without adding
yet another set.
                
> Create wrappers around Thrift Metastore objects for improved readability
> ------------------------------------------------------------------------
>
>                 Key: HIVE-3278
>                 URL: https://issues.apache.org/jira/browse/HIVE-3278
>             Project: Hive
>          Issue Type: Improvement
>          Components: Metastore
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message