hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashutosh Chauhan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-3278) Create wrappers around Thrift Metastore objects for improved readability
Date Wed, 25 Jul 2012 09:16:35 GMT

    [ https://issues.apache.org/jira/browse/HIVE-3278?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13422106#comment-13422106
] 

Ashutosh Chauhan commented on HIVE-3278:
----------------------------------------

Totally agree with Travis. We already have metastore objects represented via 2 different ways
in: {{org.apache.hadoop.hive.ql.metadata}} and {{org.apache.hadoop.hive.metastore.api}} with
logic spread across both the layers. Adding another set of wrapper objects will only increase
the confusion.
                
> Create wrappers around Thrift Metastore objects for improved readability
> ------------------------------------------------------------------------
>
>                 Key: HIVE-3278
>                 URL: https://issues.apache.org/jira/browse/HIVE-3278
>             Project: Hive
>          Issue Type: Improvement
>          Components: Metastore
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message