hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruben de Vries (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-2992) JOIN + LATERAL VIEW works, but + MAPJOIN and no longer get any results
Date Tue, 01 May 2012 12:53:49 GMT

     [ https://issues.apache.org/jira/browse/HIVE-2992?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ruben de Vries updated HIVE-2992:
---------------------------------

    Description: 
Okay first off; I know JOIN + LATERAL VIEW together isn't working so I moved my JOIN into
a subquery and that makes the query work properly

However when I added a MAPJOIN hint for the JOIN in the subquery it will also stop doing the
reducer for the main query!
This only happens when there's a LATERAL VIEW in there though, if I remove the LATERAL VIEW
then the main query still get's a reducer to do grouping


Here's a gist: https://gist.github.com/2499436 Containing the queries and a PHP script which
you can run to execute the test case I'm using, which does;
  - setup a database called hive_mapjoin
  - setup tables
  - load some test data
  - do the selects
You'll need the https://github.com/rcongiu/Hive-JSON-Serde/downloads json-serde-1.1-jar-with-dependencies.jar
with it though and change the path ;)
I guess looking at the queries you guys can probally figure out a better testcase, but maybe
it's helpful :-)


Not sure if this is a bug or me doing something that just isn't supposed to be working, but
I can't seem to find any pointers that this wouldn't be supported...


Here's another gist with the plan.xml: https://gist.github.com/2499658

  was:
Okay first off; I know JOIN + LATERAL VIEW together isn't working so I moved my JOIN into
a subquery and that makes the query work properly

However when I added a MAPJOIN hint for the JOIN in the subquery it will also stop doing the
reducer for the main query!
This only happens when there's a LATERAL VIEW in there though, if I remove the LATERAL VIEW
then the main query still get's a reducer to do grouping


Here's a gist: https://gist.github.com/2499436 Containing the queries and a PHP script which
you can run to execute the test case I'm using, which does;
  - setup a database called hive_mapjoin
  - setup tables
  - load some test data
  - do the selects
You'll need the https://github.com/rcongiu/Hive-JSON-Serde/downloads json-serde-1.1-jar-with-dependencies.jar
with it though and change the path ;)
I guess looking at the queries you guys can probally figure out a better testcase, but maybe
it's helpful :-)


Not sure if this is a bug or me doing something that just isn't supposed to be working, but
I can't seem to find any pointers that this wouldn't be supported...

    
> JOIN + LATERAL VIEW works, but + MAPJOIN and no longer get any results
> ----------------------------------------------------------------------
>
>                 Key: HIVE-2992
>                 URL: https://issues.apache.org/jira/browse/HIVE-2992
>             Project: Hive
>          Issue Type: Bug
>    Affects Versions: 0.8.1
>         Environment: ubuntu - hadoop 0.20.2-cdh3u0 - hive 0.8.1
>            Reporter: Ruben de Vries
>
> Okay first off; I know JOIN + LATERAL VIEW together isn't working so I moved my JOIN
into a subquery and that makes the query work properly
> However when I added a MAPJOIN hint for the JOIN in the subquery it will also stop doing
the reducer for the main query!
> This only happens when there's a LATERAL VIEW in there though, if I remove the LATERAL
VIEW then the main query still get's a reducer to do grouping
> Here's a gist: https://gist.github.com/2499436 Containing the queries and a PHP script
which you can run to execute the test case I'm using, which does;
>   - setup a database called hive_mapjoin
>   - setup tables
>   - load some test data
>   - do the selects
> You'll need the https://github.com/rcongiu/Hive-JSON-Serde/downloads json-serde-1.1-jar-with-dependencies.jar
with it though and change the path ;)
> I guess looking at the queries you guys can probally figure out a better testcase, but
maybe it's helpful :-)
> Not sure if this is a bug or me doing something that just isn't supposed to be working,
but I can't seem to find any pointers that this wouldn't be supported...
> Here's another gist with the plan.xml: https://gist.github.com/2499658

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message