hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Robertson <>
Subject Hive 0.9 now broken on HBase 0.90 ?
Date Wed, 18 Apr 2012 18:42:36 GMT
Hi all,

This is my first post to hive-dev so please go easy on me...

I built Hive from trunk (0.90) a couple of weeks ago and have been using it
against HBase, and today patched it with the offering of HIVE-2958 and it
all worked fine.

I just tried an Oozie workflow, built using Maven and the Apache snapshot
repository to get the 0.90 snapshot.  It fails with the following:

	at org.apache.hadoop.hive.hbase.HiveHBaseTableInputFormat.getSplits(

I believe the source of the issue could be this commit which happened after
I built from trunk a couple weeks ago:

Is there a decision to make hive 0.9  require HBase 0.92.0+ ?  It would be
awesome if it still worked on 0.90.4 since CDH3 uses that.

Hope this makes sense,
(suffering classpath hell)

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message