hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (Commented) (JIRA)" <>
Subject [jira] [Commented] (HIVE-2629) Make a single Hive binary work with both 0.20.x and 0.23.0
Date Sat, 07 Jan 2012 00:45:40 GMT


Phabricator commented on HIVE-2629:

thw has commented on the revision "HIVE-2629 [jira] Make a single Hive binary work with both
0.20.x and 0.23.0".

  Updated patch will rename directory to common-secure

  shims/build.xml:62 Looks like this was done to support pre 0.20?
  Since the classes have been moved to common in HIVE-2468 and they go into the shim jar anyways,
there should be no need for this.

  shims/build.xml:57 Done. There will be one default Hadoop version per shim implementation
and that is needed to build all shims (the desired default behavior). The user does not have
to change these for the default build but has the flexibility to do so via command line override
(for example when wanting to experiment with other Hadoop versions for existing shims).

  In addition, external builds like HCatalog can read the property file to reference the Hadoop
  build-common.xml:118-123 Results of ivy:retrieve are immutable and therefore the identifier
has to be unique for the Hadoop version to compile against multiple versions in a single ant


> Make a single Hive binary work with both 0.20.x and 0.23.0
> ----------------------------------------------------------
>                 Key: HIVE-2629
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>          Components: Shims
>            Reporter: Carl Steinbach
>            Assignee: Thomas Weise
>             Fix For: 0.9.0
>         Attachments: HIVE-2629.D711.1.patch, HIVE-2629.D711.2.patch, HIVE-2629.patch

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message