hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mithun Radhakrishnan <mithun.radhakrish...@yahoo.com>
Subject Thrift 0.9-ish
Date Wed, 04 Jan 2012 19:12:01 GMT
https://issues.apache.org/jira/browse/THRIFT-1468
I work on HCatalog (0.2). Recently, we ran into HCat_server running out of memory every few
days, and it boiled down to a bug in thrift, (recently fixed).

One sees that the HCat-0.2-branch depends on Hive-0.8, which in turn depends on thrift-0.5.0.
Hive-trunk depends on thrift-0.7.0.

I'm afraid I'm not privy to the reasoning behind Hive's dependency on a slightly dated thrift-lib.
May I please enquire if Hive can't depend on a more current version? (Does it break the metastore?)

Mithun
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message