hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (Assigned) (JIRA)" <>
Subject [jira] [Assigned] (HIVE-1877) Add java_method() as a synonym for the reflect() UDF
Date Wed, 21 Dec 2011 01:35:31 GMT


Carl Steinbach reassigned HIVE-1877:

    Assignee: Zhenxiao Luo  (was: Carl Steinbach)
> Add java_method() as a synonym for the reflect() UDF
> ----------------------------------------------------
>                 Key: HIVE-1877
>                 URL:
>             Project: Hive
>          Issue Type: Improvement
>          Components: UDF
>    Affects Versions: 0.7.0
>            Reporter: Carl Steinbach
>            Assignee: Zhenxiao Luo
>         Attachments: HIVE-1877.1.patch.txt, HIVE-1877.2.patch.txt
> HIVE-471 added the reflect() UDF which allows people to invoke static Java methods from
within HQL
> queries. In my opinion the name is confusing since it describes how the UDF works instead
of what
> it does. I propose changing the name of (or providing a synonym for) the UDF to something
>  'invoke_method' or 'java_method', or something similar. I'm open to suggestions.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message