hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-1877) Add java_method() as a synonym for the reflect() UDF
Date Sun, 25 Dec 2011 21:02:30 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1877?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13175851#comment-13175851
] 

Hudson commented on HIVE-1877:
------------------------------

Integrated in Hive-trunk-h0.23.0 #48 (See [https://builds.apache.org/job/Hive-trunk-h0.23.0/48/])
    HIVE-1877. Add java_method() as a synonym for the reflect() UDF (Zhenxiao Luo via cws)

cws : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1224646
Files : 
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java
* /hive/trunk/ql/src/test/queries/clientpositive/udf_java_method.q
* /hive/trunk/ql/src/test/results/clientpositive/show_functions.q.out
* /hive/trunk/ql/src/test/results/clientpositive/udf_java_method.q.out
* /hive/trunk/ql/src/test/results/clientpositive/udf_reflect.q.out

                
> Add java_method() as a synonym for the reflect() UDF
> ----------------------------------------------------
>
>                 Key: HIVE-1877
>                 URL: https://issues.apache.org/jira/browse/HIVE-1877
>             Project: Hive
>          Issue Type: Improvement
>          Components: UDF
>    Affects Versions: 0.7.0
>            Reporter: Carl Steinbach
>            Assignee: Zhenxiao Luo
>             Fix For: 0.9.0
>
>         Attachments: HIVE-1877.1.patch.txt, HIVE-1877.2.patch.txt, HIVE-1877.3.patch.txt
>
>
> HIVE-471 added the reflect() UDF which allows people to invoke static Java methods from
within HQL
> queries. In my opinion the name is confusing since it describes how the UDF works instead
of what
> it does. I propose changing the name of (or providing a synonym for) the UDF to something
like
>  'invoke_method' or 'java_method', or something similar. I'm open to suggestions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message