hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-727) Hive Server getSchema() returns wrong schema for "Explain" queries
Date Tue, 15 Nov 2011 22:23:52 GMT

    [ https://issues.apache.org/jira/browse/HIVE-727?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13150840#comment-13150840
] 

Carl Steinbach commented on HIVE-727:
-------------------------------------

+1. Will commit if tests pass.
                
> Hive Server getSchema() returns wrong schema for "Explain" queries
> ------------------------------------------------------------------
>
>                 Key: HIVE-727
>                 URL: https://issues.apache.org/jira/browse/HIVE-727
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Eric Hwang
>            Assignee: Prasad Mujumdar
>         Attachments: Hive-727.patch
>
>
> The Hive Server's getSchema() function will return a schema with zero fields when executing
an "Explain..." query. A quick fix might be to set the default schema to be exactly one column
of type string.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message