hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashutosh Chauhan (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-548) Code cleanup: refactor the 4 methods like SemanticAnalyzer.genGroupByPlanGroupByOperator
Date Tue, 25 Oct 2011 01:42:33 GMT

     [ https://issues.apache.org/jira/browse/HIVE-548?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ashutosh Chauhan updated HIVE-548:
----------------------------------

    Attachment: hive-548.patch

Refactoring patch aimed at avoiding code duplication.
                
> Code cleanup: refactor the 4 methods like SemanticAnalyzer.genGroupByPlanGroupByOperator
> ----------------------------------------------------------------------------------------
>
>                 Key: HIVE-548
>                 URL: https://issues.apache.org/jira/browse/HIVE-548
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Zheng Shao
>         Attachments: hive-548.patch
>
>
> We have 4 methods to generate the GroupByOperators in the SemanticAnalyzer:
> {code}
>   SemanticAnalyzer.genGroupByPlanGroupByOperator
>   SemanticAnalyzer.genGroupByPlanMapGroupByOperator
>   SemanticAnalyzer.genGroupByPlanGroupByOperator1
>   SemanticAnalyzer.genGroupByPlanGroupByOperator2
> {code}
> While they are all different, a substantial portion of them are the same. We should factor
out all the common functionality into shared functions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message