hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcin Kurczych (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-2377) USE database doesn't work when it's first command in session
Date Mon, 15 Aug 2011 23:01:27 GMT

     [ https://issues.apache.org/jira/browse/HIVE-2377?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marcin Kurczych updated HIVE-2377:
----------------------------------

    Description: 
When USE database is run as a first command it has no effect:
USE database;
SHOW TABLES;
// wrong - default database tables

When run twice it works:
USE database;
USE database;
SHOW TABLES;
// ok

When SHOW DATABASES is used before it, it works:
SHOW DATABASES;
USE database;
SHOW TABLES;
// ok

  was:
When USE database is run as a first command it has no effect:
USE database;
SHOW TABLES;
// wrong - default database tables

When run twice it works:
USE database;
USE database;
SHOW TABLES;
// ok

When SHOW DATABASES is used before it, it works:
SHOW DATABASES;
USE database;
SHOW tables;
// ok


> USE database doesn't work when it's first command in session
> ------------------------------------------------------------
>
>                 Key: HIVE-2377
>                 URL: https://issues.apache.org/jira/browse/HIVE-2377
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Marcin Kurczych
>            Priority: Minor
>
> When USE database is run as a first command it has no effect:
> USE database;
> SHOW TABLES;
> // wrong - default database tables
> When run twice it works:
> USE database;
> USE database;
> SHOW TABLES;
> // ok
> When SHOW DATABASES is used before it, it works:
> SHOW DATABASES;
> USE database;
> SHOW TABLES;
> // ok

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message