hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sameer M (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-1916) Change Default Alias For Aggregated Columns (_c1)
Date Tue, 09 Aug 2011 22:43:27 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1916?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13081981#comment-13081981
] 

Sameer M commented on HIVE-1916:
--------------------------------

Added patch for review https://reviews.apache.org/r/1441/
Default behaviour will be as before.
Adding new Hive conf vars to make the column names include the aggregation function and params.

> Change Default Alias For Aggregated Columns (_c1)
> -------------------------------------------------
>
>                 Key: HIVE-1916
>                 URL: https://issues.apache.org/jira/browse/HIVE-1916
>             Project: Hive
>          Issue Type: Improvement
>          Components: Query Processor
>         Environment: All
>            Reporter: James Mayfield
>            Priority: Minor
>
> Problem:
> When running a Hive query that aggregates (does a group by operation), Hive will automatically
name this column _c0, _c1, _c2, etc.. This is a problem because Hive will not then execute
a query against a column that begins with "_" and then the user has to manually input back-ticks
in order to get the query to run.
> Potential Solution:
> Hive should by default call these columns by their query assignment like "sum_active30day_users"
or if that is not possible, call it something simple like "column_1" so that users can then
query the new column without adding special back-ticks.
> Example Query:
> SELECT a.ds, COUNT(a.num_accounts)
> Example Result:
> ds, count_num_accounts OR ds, column_1

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message