hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ning Zhang (JIRA)" <>
Subject [jira] [Commented] (HIVE-1916) Change Default Alias For Aggregated Columns (_c1)
Date Tue, 09 Aug 2011 23:31:30 GMT


Ning Zhang commented on HIVE-1916:

sorry Carl and I were commenting on the same time. @Sameer, can you update your patch regarding
to Carl's comments? 

> Change Default Alias For Aggregated Columns (_c1)
> -------------------------------------------------
>                 Key: HIVE-1916
>                 URL:
>             Project: Hive
>          Issue Type: Improvement
>          Components: Query Processor
>         Environment: All
>            Reporter: James Mayfield
>            Priority: Minor
> Problem:
> When running a Hive query that aggregates (does a group by operation), Hive will automatically
name this column _c0, _c1, _c2, etc.. This is a problem because Hive will not then execute
a query against a column that begins with "_" and then the user has to manually input back-ticks
in order to get the query to run.
> Potential Solution:
> Hive should by default call these columns by their query assignment like "sum_active30day_users"
or if that is not possible, call it something simple like "column_1" so that users can then
query the new column without adding special back-ticks.
> Example Query:
> SELECT a.ds, COUNT(a.num_accounts)
> Example Result:
> ds, count_num_accounts OR ds, column_1

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message