hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sichi <jsi...@fb.com>
Subject Re: Hudson builds
Date Tue, 26 Jul 2011 04:54:42 GMT
Thanks, just got a clean build notification, finally!

JVS

On Jul 25, 2011, at 1:25 PM, Carl Steinbach wrote:

> The "Build" section of the job configuration had two ant invocations listed,
> and the second one didn't have any targets specified. I removed the second
> invocation and expect that this will fix the problem.
> 
> On Mon, Jul 25, 2011 at 1:18 PM, John Sichi <jsichi@fb.com> wrote:
> 
>> They've been failing consistently for 20 days.  Seems like tests are often
>> passing fine, but something else goes wrong, either right after (or during?)
>> maven, where it is trying to spawn ant?  See the very end of this log for an
>> example:
>> 
>> https://builds.apache.org/job/Hive-trunk-h0.21/846/console
>> 
>> Did some configuration change on the build machine?
>> 
>> JVS
>> 
>> ----
>> 
>> 
>> maven-publish-artifact
>> :
>> [artifact:install-provider] Installing provider:
>> org.apache.maven.wagon:wagon-http:jar:1.0-beta-2:runtime
>> [artifact:deploy] Deploying to
>> https://repository.apache.org/content/repositories/snapshots
>> 
>> [artifact:deploy] [INFO] Retrieving previous build number from
>> apache.snapshots.https
>> [artifact:deploy] Uploading:
>> org/apache/hive/hive-shims/0.8.0-SNAPSHOT/hive-shims-0.8.0-20110725.192514-42.jar
>> to repository apache.snapshots.https at
>> https://repository.apache.org/content/repositories/snapshots
>> 
>> [artifact:deploy] Transferring 76K from apache.snapshots.https
>> [artifact:deploy] Uploaded 76K
>> [artifact:deploy] [INFO] Retrieving previous metadata from
>> apache.snapshots.https
>> [artifact:deploy] [INFO] Uploading repository metadata for: 'snapshot
>> org.apache.hive:hive-shims:0.8.0-SNAPSHOT'
>> [artifact:deploy] [INFO] Retrieving previous metadata from
>> apache.snapshots.https
>> [artifact:deploy] [INFO] Uploading repository metadata for: 'artifact
>> org.apache.hive:hive-shims'
>> [artifact:deploy] [INFO] Uploading project information for hive-shims
>> 0.8.0-20110725.192514-42
>> 
>> 
>> BUILD SUCCESSFUL
>> 
>> Total time: 207 minutes 4 seconds
>> [hive] $ ant
>> FATAL: command execution failed.Maybe you need to configure the job to
>> choose one of your Ant installations?
>> 
>> java.io.IOException
>> : Cannot run program "ant" (in directory
>> "/home/jenkins/jenkins-slave/workspace/Hive-trunk-h0.21/hive"):
>> java.io.IOException: error=2, No such file or directory
>>       at
>> java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
>> 
>>       at
>> hudson.Proc$LocalProc.<init>(Proc.java:244)
>> 
>>       at
>> hudson.Proc$LocalProc.<init>(Proc.java:216)
>> 
>>       at
>> hudson.Launcher$LocalLauncher.launch(Launcher.java:698)
>> 
>>       at
>> hudson.Launcher$ProcStarter.start(Launcher.java:329)


Mime
View raw message