hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <>
Subject [jira] Updated: (HIVE-751) Rename serde/serdeFormat etc in Hive.g for readability
Date Mon, 07 Mar 2011 20:23:59 GMT


Carl Steinbach updated HIVE-751:

    Fix Version/s: 0.5.0

> Rename serde/serdeFormat etc in Hive.g for readability
> ------------------------------------------------------
>                 Key: HIVE-751
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>          Components: Query Processor
>            Reporter: Namit Jain
>            Assignee: Namit Jain
>             Fix For: 0.5.0
> @hive.743.2.patch:
> Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde",
"serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can
also replace "tableRowFormat" with "rowFormat".
> SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for
inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to
get all corresponding children?
> We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't
need to calculate the child positions.
> Otherwise it looks good.

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message