hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amareshwari Sriramadasu (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HIVE-1877) Add java_method() as a synonym for the reflect() UDF
Date Mon, 14 Mar 2011 05:02:29 GMT

     [ https://issues.apache.org/jira/browse/HIVE-1877?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Amareshwari Sriramadasu updated HIVE-1877:
------------------------------------------

    Status: Open  (was: Patch Available)

Patch does not apply cleanly. Can you regenerate? I will run tests and commit, once new patch
is uploaded.

> Add java_method() as a synonym for the reflect() UDF
> ----------------------------------------------------
>
>                 Key: HIVE-1877
>                 URL: https://issues.apache.org/jira/browse/HIVE-1877
>             Project: Hive
>          Issue Type: Improvement
>          Components: UDF
>    Affects Versions: 0.7.0
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>         Attachments: HIVE-1877.1.patch.txt, HIVE-1877.2.patch.txt
>
>
> HIVE-471 added the reflect() UDF which allows people to invoke static Java methods from
within HQL
> queries. In my opinion the name is confusing since it describes how the UDF works instead
of what
> it does. I propose changing the name of (or providing a synonym for) the UDF to something
like
>  'invoke_method' or 'java_method', or something similar. I'm open to suggestions.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message