hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bharath vissapragada <bharathvissapragada1...@gmail.com>
Subject Running Hive from eclipse
Date Thu, 10 Feb 2011 12:02:35 GMT
Hi all,

I loaded Hive source as a java project in eclipse using the ant build.
I modified source and I am trying to fire Hive queries my adding a
main function to "ql/Driver.java" .. Following is the trace I get
after issuing the query..

====================================================
11/02/10 17:09:51 INFO ql.Driver: received the command:select * from
page_view JOIN page_view1 ON (page_view.country = page_view1.country)
11/02/10 17:09:51 INFO ql.Driver: compiling the command:select * from
page_view JOIN page_view1 ON (page_view.country = page_view1.country)
FAILED: Hive Internal Error: java.lang.NullPointerException(null)
java.lang.NullPointerException
	at org.apache.hadoop.hive.ql.parse.VariableSubstitution.substitute(VariableSubstitution.java:20)
	at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:326)
	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:745)
	at org.apache.hadoop.hive.ql.Driver.main(Driver.java:737)

11/02/10 17:09:51 ERROR ql.Driver: FAILED: Hive Internal Error:
java.lang.NullPointerException(null)
java.lang.NullPointerException
	at org.apache.hadoop.hive.ql.parse.VariableSubstitution.substitute(VariableSubstitution.java:20)
	at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:326)
	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:745)
	at org.apache.hadoop.hive.ql.Driver.main(Driver.java:737)

Exception in thread "main" java.lang.NullPointerException
	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:747)
	at org.apache.hadoop.hive.ql.Driver.main(Driver.java:737)

========================================================

1st 2 lines are my logging statements for the query and I think this
error is due to the misconfiguration of the metastore.

Following is my conf/hive-default.xml (meta-store related settings)

<property>
  <name>javax.jdo.option.ConnectionURL</name>
  <value>jdbc:mysql://localhost/hive_meta?createDatabaseIfNotExist=true </value>
  <description>JDBC connect string for a JDBC metastore</description>
</property>

<property>
  <name>javax.jdo.option.ConnectionDriverName</name>
  <value>com.mysql.jdbc.Driver</value>
  <description>Driver class name for a JDBC metastore</description>
</property>
<property>
  <name>javax.jdo.option.ConnectionUserName</name>
  <value>root</value>
  <description>username to use against metastore database</description>
</property>

<property>
  <name>javax.jdo.option.ConnectionPassword</name>
  <value></value>
  <description>password to use against metastore database</description>
</property>


Even after running the query I dont see any databsase named
"hive_meta" created in my mysql database. My tables are empty .. can
this be the reason???


Thanks
Bharath .V
w:http://research.iiit.ac.in/bharath.v

Mime
View raw message