hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sichi <jsi...@fb.com>
Subject cli dependency change
Date Wed, 16 Feb 2011 18:22:42 GMT
After you svn up the commit for HIVE-1817 and do ant clean package, you may get errors like
the ones below.  If so, it means you were relying on the Hadoop 0.20.0 tarball we use for
Hive development, and you need to update your $HADOOP_HOME to point to

hive-trunk/build/hadoopcore/hadoop-0.20.1 instead of 0.20.0

Errors:

"Cannot find hadoop installation: $HADOOP_HOME must be set or hadoop must be in the path"

"Hive requires Hadoop 0.20.x (x >= 1).
'hadoop version' returned:
Hadoop 0.20.0 Subversion https://svn.apache.org/repos/asf/hadoop/core/branches/branch-0.20
-r 763504 Compiled by ndaley on Thu Apr 9 05:18:40 UTC 2009"

JVS


Mime
View raw message