hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ning Zhang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1962) make a libthrift.jar and libfb303.jar in dist package for backward compatibility
Date Sat, 05 Feb 2011 01:16:31 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1962?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12990861#comment-12990861
] 

Ning Zhang commented on HIVE-1962:
----------------------------------

cool. I also just found out the ant package issue. I'll upload a new patch soon. 

> make a libthrift.jar and libfb303.jar in dist package for backward compatibility
> --------------------------------------------------------------------------------
>
>                 Key: HIVE-1962
>                 URL: https://issues.apache.org/jira/browse/HIVE-1962
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Ning Zhang
>            Assignee: Ning Zhang
>         Attachments: HIVE-1962.patch
>
>
> We have seen an internal user that relies on Hive's distribution library libthrift.jar.
After the upgrade of thrift jar to 0.5.0, the jar file is renamed to thrift-0.5.0.jar and
similarly for the fb303 jar. We can ask the user to change their dependency to thrift-0.5.0.jar,
but later when we upgrade to a new version, the dependency breaks again. It's desirable to
create a symlink in the dist/lib directory to link libthrift.jar to thrift-${thrift.version}.jar
and the same for fb303. 

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message