hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Sichi (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HIVE-1817) Remove Hive dependency on unreleased commons-cli 2.0 Snapshot
Date Mon, 14 Feb 2011 21:01:57 GMT

     [ https://issues.apache.org/jira/browse/HIVE-1817?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Sichi updated HIVE-1817:
-----------------------------

    Status: Open  (was: Patch Available)

I'm getting the build failure below.  I think it's because you added ivy-retrieve to the compile
target in build-common.xml.

{noformat}
ivy-resolve:
[ivy:resolve] :: Ivy 2.1.0 - 20090925235825 :: http://ant.apache.org/ivy/ ::
[ivy:resolve] :: loading settings :: file = /data/users/jsichi/open/test-trunk/ivy/ivysettings.xml
[ivy:resolve] /data/users/jsichi/open/test-trunk/odbc/ivy.xml (No such file or directory)
in file:/data/users/jsichi/open/test-trunk/odbc/ivy.xml

BUILD FAILED
/data/users/jsichi/open/test-trunk/build.xml:200: The following error occurred while executing
this line:
/data/users/jsichi/open/test-trunk/build.xml:96: The following error occurred while executing
this line:
/data/users/jsichi/open/test-trunk/build-common.xml:163: syntax errors in ivy file: java.text.ParseException:
/data/users/jsichi/open/test-trunk/odbc/ivy.xml (No such file or directory) in file:/data/users/jsichi/open/test-trunk/odbc/ivy.xml
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.parse(XmlModuleDescriptorParser.java:263)
{noformat}


> Remove Hive dependency on unreleased commons-cli 2.0 Snapshot
> -------------------------------------------------------------
>
>                 Key: HIVE-1817
>                 URL: https://issues.apache.org/jira/browse/HIVE-1817
>             Project: Hive
>          Issue Type: Task
>          Components: Build Infrastructure, CLI
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>            Priority: Blocker
>             Fix For: 0.7.0
>
>         Attachments: HIVE-1817.2.patch.txt, HIVE-1817.wip.1.patch.txt
>
>
> The Hive CLI depends on commons-cli-2.0-SNAPSHOT. This branch of of the commons-cli project
is dead.
> Hive needs to use commons-cli-1.2 instead. See MAPREDUCE-767 for more information.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message