hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jinsong Hu" <>
Subject Re: retirement of in new version of hadoop
Date Mon, 08 Nov 2010 23:14:21 GMT
I am very  interested in hive_hbase-handler in 0.6 version of hive. I have 
compiled the hive trunk's  hive_hbase-handler  and got it working with 
cdh3b2's hbase after some minor code change. However, in my testing, I found
that cdh3b2's hbase is not stable enough. I tested cdh3b3's hbase and I 
found it was much better. However,
when I tried to get hive to work with it, I found that neither hive 0.6 nor 
the hive trunk are compatible with cdh3b3 hbase, as they use 
UnixUserGroupInformation .

the hive released with cdh3b3 is still 0.5 version. it doesn't have the 
hive_hbase-handler . and according to my reading, hive itself needs a patch 
HIVE-705 in order to work with hive_hbase-handler, and hive-0.5 version 
doesn't have that patch. This means I can't really use the hive shipped with 
cdh3b3. and compiling hive-0.6 so it work with cdh3b3 is my best hope.

Which goes back to the question: can se use  UserGroupInformation to replace 
in hive-0.6 ?


From: "Vinithra Varadharajan" <>
Sent: Monday, November 08, 2010 2:52 PM
To: <>; <>
Cc: <>
Subject: Re: retirement of in new version of hadoop

> Hi Jimmy,
> cdh3b3 Hadoop includes the patches written by Yahoo! to introduce
> authentication based on Kerberos. These patches include removal of
> UnixUserGroupInformation. cdh3b3's Hive release includes patches to
> to not use UnixUserGroupInformation and instead make calls to 
> a
> shim layer that works with the authentication system in Hadoop.
> Are there features in hive trunk/0.6 that you are interested in using but
> are not available in cdh3b3 Hive?
> -Vinithra
> On Mon, Nov 8, 2010 at 12:28 PM, Jinsong Hu <> 
> wrote:
>> Hi, There:
>>  I was trying to compile trunk version of hive with cloudera cdh3b3
>> distribution and noticed that in
>> org.apache.hadoop.hive.ql was using:
>> However, in the cdh3b3 version of hadoop, this class is gone, so
>> doesn't compile.
>> I checked 0.6 version of hive, the same issue exists.
>> I noticed that class is
>> still there, both
>> in cdh3b2 and cdh3b3 version of hadoop. Can we change the to
>> use
>> instead ? This class does sound like a more generic class that in the
>> future, we may
>> even get it to work under windows or other os.
>> Jimmy.

View raw message