hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Watt (JIRA)" <>
Subject [jira] Commented: (HIVE-1646) Hive 0.5 Build Crashing
Date Thu, 16 Sep 2010 19:29:32 GMT


Stephen Watt commented on HIVE-1646:

@Steven thanks for the comment. When a build is successful I would it expect it to complete,
and then provide a report of which test cases failed. You can then use that to debug each
test case individually in eclipse. This is at least the way it works with the Hadoop build.
With this Hive build, it appears the actual build is crashing as it never gets to the point
where the build completes and it provides the ant build report. I would expect for an official
Hive release for the build to at least complete without crashing, even if there are one or
two test cases that fail. 

Does your build on OS/X actually complete and you see the build report? i.e.  You are not
seeing this failure message?
/home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:151: The following error occurred while
executing this line:
/home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:91: The following error occurred while
executing this line:
/home/hive/hive-0.5.0-build/hive-0.5.0-dev/build-common.xml:327: Tests failed!

> Hive 0.5 Build Crashing
> -----------------------
>                 Key: HIVE-1646
>                 URL:
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Testing Infrastructure
>    Affects Versions: 0.5.0
>         Environment: SLES 10 SP2, SLES 11, RHEL 5.4, ANT 1.8.1 and ANT 1.7.1, SUN JDK
>            Reporter: Stephen Watt
>             Fix For: 0.5.1
> I've tried this on a variety of configurations. Operating Systems SLES 10 SP2, SLES 11,
RHEL 5.4 on a variety of machines using both ANT 1.8.1 and ANT 1.7.1 and SUN JDK 1.6.14. I've
tried building this by going to the Hive Release page and download hive-0.5.0-src and using
that. I've tried building by obtaining the branch tag release using svn checkout
hive-0.5.0-dev. Always the same thing:
> When I run the Hive 0.5 build it runs for just under 2 hours and then crashes with the
following message (tail end of ant.log):
> - - -
>     [junit] diff /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build/ql/test/logs/negative/wrong_distinct2.q.out
>     [junit] Done query: wrong_distinct2.q
>     [junit] Tests run: 31, Failures: 0, Errors: 0, Time elapsed: 90.974 sec
>     [junit] Running org.apache.hadoop.hive.ql.tool.TestLineageInfo
>     [junit] Tests run: 5, Failures: 0, Errors: 0, Time elapsed: 0.525 sec
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:151: The following error occurred
while executing this line:
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:91: The following error occurred
while executing this line:
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build-common.xml:327: Tests failed!
> Total time: 94 minutes 43 seconds
> - - -
> My build script is very simplistic :
> #!/bin/sh
> # Set Build Dependencies
> set PATH=$PATH:/home/hive/Java-Versions/jdk1.6.0_14/bin/
> export JAVA_HOME=/home/hive/Java-Versions/jdk1.6.0_14
> export BUILD_DIR=/home/hive/hive-0.5.0-build
> export ANT_HOME=$BUILD_DIR/apache-ant-1.8.1
> export HIVE_INSTALL=$BUILD_DIR/hive-0.5.0-dev/
> export PATH=$PATH:$ANT_HOME/bin
> # Run Build and Unit Test
> ant clean test tar -logfile ant.log

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message