hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Steinbach <>
Subject Re: Alter table for rename column is not working
Date Tue, 15 Jun 2010 07:13:44 GMT
HI Jaydeep,

The ability to change column names first became available in Hive 0.5. This
feature is not present in Hive 0.4.1 or any earlier release. I tried your
example on Hive 0.4.1 and verified that it fails with the same error. It
works on Hive 0.5.



On Mon, Jun 14, 2010 at 11:28 PM, jaydeep vishwakarma <> wrote:

> Hi,
> I just copied and pasted hive tutorial example. I dont know why column
> rename is working,
> I ran following statement:
> hive> CREATE TABLE test_change (a int, b int, c int);
> OK
> Time taken: 0.227 seconds
> hive> ALTER TABLE test_change CHANGE a a1 INT;
> FAILED: Parse Error: line 1:12 cannot recognize input 'test_change' in
> alter statement
> Regards,
> Jaydeep
> The information contained in this communication is intended solely for the
> use of the individual or entity to whom it is addressed and others
> authorized to receive it. It may contain confidential or legally privileged
> information. If you are not the intended recipient you are hereby notified
> that any disclosure, copying, distribution or taking any action in reliance
> on the contents of this information is strictly prohibited and may be
> unlawful. If you have received this communication in error, please notify us
> immediately by responding to this email and then delete it from your system.
> The firm is neither liable for the proper and complete transmission of the
> information contained in this communication nor for any delay in its
> receipt.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message