hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <>
Subject [jira] Commented: (HIVE-1192) Build fails when hadoop.version=0.20.1
Date Tue, 23 Feb 2010 19:59:28 GMT


Carl Steinbach commented on HIVE-1192:

For this particular application I don't think the patch numbers matter. We download
the Hadoop tarballs in order to obtain the jars which are referenced when the
shims are built in order to satisfy the compiler. Since the API does not change between
patch versions there is no difference between using 0.20.1 and 0.20.0, etc for this
step. Subsequently, the contents of these tarballs are not referenced at all --
we expect users to supply their own installation of Hadoop. I think it's a bug
that our build currently thinks there is a difference between 0.20.0 and 0.20.1.
Am I missing something?

> Build fails when hadoop.version=0.20.1
> --------------------------------------
>                 Key: HIVE-1192
>                 URL:
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>            Reporter: Carl Steinbach
> Setting hadoop.version=0.20.1 causes the build to fail since
> does not have 0.20.1
> (only, 0.18.3, 0.19.0, 0.20.0).
> Suggested fix:
> * remove/ignore the hadoop.version configuration parameter
> or
> * Remove the patch numbers from these archives and use only the major.minor numbers specified
by the user to locate the appropriate tarball to download, so 0.20.0 and 0.20.1 would both
map to hadoop-0.20.tar.gz.
> * Optionally create new tarballs that only contain the components that are actually needed
for the build (Hadoop jars), and remove things that aren't needed (all of the source files).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message