hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zheng Shao (JIRA)" <>
Subject [jira] Commented: (HIVE-549) Parallel Execution Mechanism
Date Sun, 01 Nov 2009 23:02:59 GMT


Zheng Shao commented on HIVE-549:

Can you add javadoc comments to all public methods (except getters and setters)? I know we
were not following that all the time historically, but we want to enforce that on all new

It seems to me that "shouldLaunch()" is a better name than "checkLaunch()", but it's up to
you whether you would like to change it.

Can we change the name of "hive.optimize.par" to "hive.execution.parallel"?
"optimize" was meant for plan optimization. This is an execution time option. Also "par" does
not reflect to "parallel" in my mind.

> Parallel Execution Mechanism
> ----------------------------
>                 Key: HIVE-549
>                 URL:
>             Project: Hadoop Hive
>          Issue Type: Wish
>          Components: Query Processor
>            Reporter: Adam Kramer
>            Assignee: Chaitanya Mishra
>         Attachments: HIVE-549-v3.patch
> In a massively parallel database system, it would be awesome to also parallelize some
of the mapreduce phases that our data needs to go through.
> One example that just occurred to me is UNION ALL: when you union two SELECT statements,
effectively you could run those statements in parallel. There's no situation (that I can think
of, but I don't have a formal proof) in which the left statement would rely on the right statement,
or vice versa. So, they could be run at the same time...and perhaps they should be. Or, perhaps
there should be a way to make this happen...PARALLEL UNION ALL? PUNION ALL?

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message