hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Namit Jain (JIRA)" <>
Subject [jira] Resolved: (HIVE-751) Rename serde/serdeFormat etc in Hive.g for readability
Date Tue, 01 Sep 2009 22:25:33 GMT


Namit Jain resolved HIVE-751.

      Resolution: Fixed
    Hadoop Flags: [Reviewed]

fixed as part of 785

> Rename serde/serdeFormat etc in Hive.g for readability
> ------------------------------------------------------
>                 Key: HIVE-751
>                 URL:
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Query Processor
>            Reporter: Namit Jain
>            Assignee: Namit Jain
> @hive.743.2.patch:
> Hive.g: Can we use "rowFormat", "rowFormatDelimited", "rowFormatSerDe" instead of "serde",
"serdePropertiesFormat", and "serdeFormat"? I think that will be much more intuitive. We can
also replace "tableRowFormat" with "rowFormat".
> SemanticAnalyzer.genScriptPlan looks a bit ugly - can we add one level of nesting for
inSerDe and outSerDe in Hive.g, and use a single loop over the children in genScriptPlan to
get all corresponding children?
> We can also add a "null" placeholder in case inSerDe / outSerDe is missing, so we don't
need to calculate the child positions.
> Otherwise it looks good.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message