hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghotham Murthy (JIRA)" <>
Subject [jira] Created: (HIVE-714) Rename classes to make them more understandable
Date Fri, 31 Jul 2009 17:11:14 GMT
Rename classes to make them more understandable

                 Key: HIVE-714
             Project: Hadoop Hive
          Issue Type: Improvement
          Components: Query Processor
            Reporter: Raghotham Murthy

Right now there are a few class names which are quite confusing - we should rename them to
be more clear. Here's the initial list of classes. There are probably others.

ExecDriver -> MapRedTask
MapRedTask -> LocalMapRedTask
FetchOperator -> either make it extend Operator, or call it something like FileReader

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message