hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Pestritto <>
Subject Trunk runtime errors
Date Wed, 13 May 2009 16:04:38 GMT
All -

1st problem.
I was having a problem loading data into partitions when the partition did
not exist and traced the problem to revision 772746.  Trunk also has the
same error.
Revision 772746 SVN Commend:  HIVE-442. Create partitions after data is
moved in the query in order to close out an inconsistent window. (Prasad
Chakka via athusoo)
Revision 772012 works fine for me.

Essentially the partition directories are created but the data is never
copied over.  If I run the same job again, the data is copied to the target
directory in HDFS.

2nd problem.
When I try to do a select count(1) from a table I get the following
exception and I'm not sure what the cause is.  Again, this works fine if I
roll back to revision 772012.
Job Submission failed with exception
'java.lang.IllegalArgumentException(Wrong FS: file:/tmp/hive-hive/1,
expected: hdfs://'
FAILED: Execution Error, return code 1 from

Let me know if I can facilitate further.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message