hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish Thusoo <athu...@facebook.com>
Subject RE: Eclipse run fails !!
Date Tue, 03 Feb 2009 22:41:12 GMT
Actually for running hive through eclipse you don't need to download and start hadoop. Hive
tests automatically create a local instance of hdfs and map/reduce and are able to run it.

The errors that you are getting seem to indicate some jpox plugins missing in eclipse. Prasad
is an expert in that area and can perhaps comment on that...

Ashish

-----Original Message-----
From: Shyam Sarkar [mailto:shyam_sarkar@yahoo.com]
Sent: Tuesday, February 03, 2009 2:30 PM
To: hive-dev@hadoop.apache.org; Ashish Thusoo
Subject: RE: Eclipse run fails !!

Dear Ashish,

I downloaded hadoop 0.17.0 and tried bin/start-all.sh script. I got one error ::
==============================================================
[ssarkar@ayush2 hadoop-0.17.0]$ bin/start-all.sh starting namenode, logging to /home/ssarkar/hadoop/hadoop-0.17.0/bin/../logs/hadoop-ssarkar-namenode-ayush2.out
ssarkar@localhost's password:
localhost: starting datanode, logging to /home/ssarkar/hadoop/hadoop-0.17.0/bin/../logs/hadoop-ssarkar-datanode-ayush2.out
ssarkar@localhost's password:
localhost: starting secondarynamenode, logging to /home/ssarkar/hadoop/hadoop-0.17.0/bin/../logs/hadoop-ssarkar-secondarynamenode-ayush2.out
localhost: Exception in thread "main" java.lang.NullPointerException
localhost:      at org.apache.hadoop.net.NetUtils.createSocketAddr(NetUtils.java:119)
localhost:      at org.apache.hadoop.dfs.SecondaryNameNode.<init>(SecondaryNameNode.java:118)
localhost:      at org.apache.hadoop.dfs.SecondaryNameNode.main(SecondaryNameNode.java:495)
starting jobtracker, logging to /home/ssarkar/hadoop/hadoop-0.17.0/bin/../logs/hadoop-ssarkar-jobtracker-ayush2.out
ssarkar@localhost's password:
localhost: starting tasktracker, logging to /home/ssarkar/hadoop/hadoop-0.17.0/bin/../logs/hadoop-ssarkar-tasktracker-ayush2.out
[ssarkar@ayush2 hadoop-0.17.0]$
===================================================================

Next I loaded hive project into eclipse following steps in hive wiki.
I tried Run->Run Configurations->JUnit and selected TestTruncate to run but got the
following error ::

"Errors exist in required Projest(s):

hive

Proceed with Launch ?"

When I launch I got following errors ::

=================================================================
09/02/03 14:01:33 INFO metastore.HiveMetaStore: 0: Opening raw store with implemenation class:org.apache.hadoop.hive.metastore.ObjectStore
09/02/03 14:01:33 INFO metastore.ObjectStore: ObjectStore, initialize called
09/02/03 14:01:33 INFO metastore.ObjectStore: found resource jpox.properties at file:/home/ssarkar/hive/conf/jpox.properties
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.views" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.perspectiveExtensions"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.preferencePages" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.keywords" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.debug.core.launchConfigurationTypes"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.debug.core.launchConfigurationComparators"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.debug.ui.launchConfigurationTypeImages"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.debug.ui.launchConfigurationTabGroups"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.newWizards" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.popupMenus" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.actionSets" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.actionSetPartAssociations"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.debug.ui.launchShortcuts"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.jdt.core.classpathVariableInitializer"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.jdt.ui.quickFixProcessors"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.jdt.ui.classpathFixProcessors"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.ide.markerResolution"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.core.expressions.propertyTesters"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ltk.core.refactoring.renameParticipants"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.commands" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.ui.bindings" not registered,
but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.core.runtime.preferences"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.jdt.core.classpathContainerInitializer"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 WARN JPOX.Plugin: Extension Point "org.eclipse.jdt.ui.classpathContainerPage"
not registered, but plugin "org.eclipse.jdt.junit" defined in file:/home/ssarkar/eclipse/eclipse32_3.4.1_working/configuration/org.eclipse.osgi/bundles/97/1/.cp/META-INF/MANIFEST.MF
refers to it.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ui.ide"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ui.views"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.jface.text"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ui.workbench.texteditor"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ui.editors"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ui"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.core.expressions"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.core.resources"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.debug.core"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.debug.ui"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.jdt.core"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.jdt.ui"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.core.runtime"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.jdt.launching"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.jdt.debug.ui"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.compare"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ltk.core.refactoring"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.core.variables"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit" requires "org.eclipse.ltk.ui.refactoring"
but it cannot be resolved.
09/02/03 14:01:33 ERROR JPOX.Plugin: Bundle "org.eclipse.jdt.junit.runtime" requires "org.junit"
but it cannot be resolved.
09/02/03 14:01:33 WARN JPOX.Plugin: Bundle "org.jpox" has an optional dependency to "org.eclipse.equinox.registry"
but it cannot be resolved
09/02/03 14:01:33 WARN JPOX.Plugin: Bundle "org.jpox" has an optional dependency to "org.eclipse.core.runtime"
but it cannot be resolved
09/02/03 14:01:33 INFO JPOX.Persistence: ================= Persistence Configuration ===============
09/02/03 14:01:33 INFO JPOX.Persistence: JPOX Persistence Factory - Vendor: "JPOX"  Version:
"1.2.2"
09/02/03 14:01:33 INFO JPOX.Persistence: JPOX Persistence Factory initialised for datastore
URL="jdbc:derby:;databaseName=../build/test/junit_metastore_db;create=true" driver="org.apache.derby.jdbc.EmbeddedDriver"
userName="APP"
09/02/03 14:01:33 INFO JPOX.Persistence: ===========================================================
09/02/03 14:01:35 INFO Datastore.Schema: Initialising Catalog "", Schema "APP" using "SchemaTable"
auto-start option
09/02/03 14:01:36 INFO Datastore.Schema: Catalog "", Schema "APP" initialised - managing 0
classes
09/02/03 14:01:36 INFO JPOX.JDO: >> Found StoreManager org.jpox.store.rdbms.RDBMSManager
java.lang.UnsupportedClassVersionError: Bad version number in .class file
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
        at org.apache.hadoop.hive.metastore.ObjectStore.getPMF(ObjectStore.java:180)
        at org.apache.hadoop.hive.metastore.ObjectStore.getPersistenceManager(ObjectStore.java:194)
        at org.apache.hadoop.hive.metastore.ObjectStore.initialize(ObjectStore.java:124)
        at org.apache.hadoop.hive.metastore.ObjectStore.setConf(ObjectStore.java:103)
        at org.apache.hadoop.util.ReflectionUtils.setConf(ReflectionUtils.java:54)
        at org.apache.hadoop.util.ReflectionUtils.newInstance(ReflectionUtils.java:82)
        at org.apache.hadoop.hive.metastore.HiveMetaStore$HMSHandler.getMS(HiveMetaStore.java:127)
        at org.apache.hadoop.hive.metastore.HiveMetaStore$HMSHandler.createDefaultDB(HiveMetaStore.java:143)
        at org.apache.hadoop.hive.metastore.HiveMetaStore$HMSHandler.init(HiveMetaStore.java:115)
        at org.apache.hadoop.hive.metastore.HiveMetaStore$HMSHandler.<init>(HiveMetaStore.java:100)
        at org.apache.hadoop.hive.metastore.HiveMetaStoreClient.<init>(HiveMetaStoreClient.java:73)
        at org.apache.hadoop.hive.ql.metadata.Hive.createMetaStoreClient(Hive.java:785)
        at org.apache.hadoop.hive.ql.metadata.Hive.getMSC(Hive.java:798)
        at org.apache.hadoop.hive.ql.metadata.Hive.dropTable(Hive.java:316)
        at org.apache.hadoop.hive.ql.metadata.Hive.dropTable(Hive.java:300)
        at org.apache.hadoop.hive.ql.exec.TestExecDriver.<clinit>(TestExecDriver.java:105)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at junit.framework.TestSuite.createTest(TestSuite.java:131)
        at junit.framework.TestSuite.addTestMethod(TestSuite.java:114)
        at junit.framework.TestSuite.<init>(TestSuite.java:75)
        at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader.getTest(JUnit3TestLoader.java:102)
        at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader.loadTests(JUnit3TestLoader.java:59)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:445)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
java.lang.ExceptionInInitializerError
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at junit.framework.TestSuite.createTest(TestSuite.java:131)
        at junit.framework.TestSuite.addTestMethod(TestSuite.java:114)
        at junit.framework.TestSuite.<init>(TestSuite.java:75)
        at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader.getTest(JUnit3TestLoader.java:102)
        at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestLoader.loadTests(JUnit3TestLoader.java:59)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:445)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
Caused by: java.lang.RuntimeException: Encountered throwable
        at org.apache.hadoop.hive.ql.exec.TestExecDriver.<clinit>(TestExecDriver.java:113)
        ... 13 more
======================================================================

regards,
Shyam





--- On Tue, 2/3/09, Ashish Thusoo <athusoo@facebook.com> wrote:

> From: Ashish Thusoo <athusoo@facebook.com>
> Subject: RE: Eclipse run fails !!
> To: "Shyam Sarkar" <shyam_sarkar@yahoo.com>,
> "hive-dev@hadoop.apache.org" <hive-dev@hadoop.apache.org>
> Date: Tuesday, February 3, 2009, 1:46 PM Hi Shyam,
>
> I can certainly say that 0.17.0 should work with eclipse. I have been
> doing that for a while.
>
> Maybe we can concentrate on fixing why you are not able to create a
> table in hdfs. I am not sure why you could not create the
> /user/hive/warehouse directory in 0.17. Are you saying that
>
> hadoop dfs -mkdir /user/facebook/hive
>
> does not work for you? Can you send out the output when you run this
> command.
>
> Ashish
>
> PS: using -Dhadoop.versoion="0.17.0" for all the commands that are
> given in the wiki should make things work in eclipse.
>
> -----Original Message-----
> From: Shyam Sarkar [mailto:shyam_sarkar@yahoo.com]
> Sent: Tuesday, February 03, 2009 12:00 PM
> To: hive-dev@hadoop.apache.org; Ashish Thusoo
> Subject: RE: Eclipse run fails !!
>
> Dear Ashish,
>
> For the last few days I tried eclipse 3.4.1 with 0.17.2.1 version and
> got the same errors with run->run. Then I looked into bin/hive command
> and found that it could not create table in HDFS. The reason was that
> I could not create /user/hive/warehouse directory inside HDFS. It was
> using Linux FS.
> This is why I switched to 0.19.0 where directories in HDFS can be
> created.
>
> Could you please tell me which exact version of hadoop will work fine
> with eclipse runs ?  I want to get rid of errors in project itself
> (before any run).
>
> Regards,
> Shyam
>
> --- On Tue, 2/3/09, Ashish Thusoo
> <athusoo@facebook.com> wrote:
>
> > From: Ashish Thusoo <athusoo@facebook.com>
> > Subject: RE: Eclipse run fails !!
> > To: "hive-dev@hadoop.apache.org"
> <hive-dev@hadoop.apache.org>,
> > "shyam_sarkar@yahoo.com"
> <shyam_sarkar@yahoo.com>
> > Date: Tuesday, February 3, 2009, 11:38 AM Hi Shyam,
> >
> > We have not really tried the eclipse stuff for 0.19.0.
> Is it possible
> > for you to use 0.17.0 for now, while we figure this
> out...
> >
> > Ashish
> >
> > -----Original Message-----
> > From: Shyam Sarkar [mailto:shyam_sarkar@yahoo.com]
> > Sent: Tuesday, February 03, 2009 11:26 AM
> > To: hive-dev@hadoop.apache.org
> > Subject: Eclipse run fails !!
> >
> > Hello,
> >
> > I have hive project loaded inside eclipse 3.4.1 and
> hadoop 0.19.0 is
> > running in the background. I could create tables from
> bin/hive
> > command.
> > But when I try to run->run inside eclipse it says::
> >
> > "Errors exist with required project(s):
> >
> > hive
> >
> > Proceed with launch ?"
> >
> > and then it gives many errors.
> >
> > Can someone please tell me why there are errors in
> project hive ?  I
> > followed all steps correctly from hive wiki.
> >
> > Regards,
> > shyam_sarkar@yahoo.com




Mime
View raw message