hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish Thusoo <>
Subject RE: Eclipse run fails !!
Date Tue, 03 Feb 2009 21:46:27 GMT
Hi Shyam,

I can certainly say that 0.17.0 should work with eclipse. I have been doing that for a while.

Maybe we can concentrate on fixing why you are not able to create a table in hdfs. I am not
sure why you could not create the /user/hive/warehouse directory in 0.17. Are you saying that

hadoop dfs -mkdir /user/facebook/hive

does not work for you? Can you send out the output when you run this command.


PS: using -Dhadoop.versoion="0.17.0" for all the commands that are given in the wiki should
make things work in eclipse. 

-----Original Message-----
From: Shyam Sarkar [] 
Sent: Tuesday, February 03, 2009 12:00 PM
To:; Ashish Thusoo
Subject: RE: Eclipse run fails !!

Dear Ashish,

For the last few days I tried eclipse 3.4.1 with version and got the same errors
with run->run. Then I looked into bin/hive command and found that it could not create table
in HDFS. The reason was that I could not create /user/hive/warehouse directory inside HDFS.
It was using Linux FS.
This is why I switched to 0.19.0 where directories in HDFS can be created.

Could you please tell me which exact version of hadoop will work fine with eclipse runs ?
 I want to get rid of errors in project itself (before any run).


--- On Tue, 2/3/09, Ashish Thusoo <> wrote:

> From: Ashish Thusoo <>
> Subject: RE: Eclipse run fails !!
> To: "" <>, 
> "" <>
> Date: Tuesday, February 3, 2009, 11:38 AM Hi Shyam,
> We have not really tried the eclipse stuff for 0.19.0. Is it possible 
> for you to use 0.17.0 for now, while we figure this out...
> Ashish
> -----Original Message-----
> From: Shyam Sarkar []
> Sent: Tuesday, February 03, 2009 11:26 AM
> To:
> Subject: Eclipse run fails !!
> Hello,
> I have hive project loaded inside eclipse 3.4.1 and hadoop 0.19.0 is 
> running in the background. I could create tables from bin/hive 
> command.
> But when I try to run->run inside eclipse it says::
> "Errors exist with required project(s):
> hive
> Proceed with launch ?"
> and then it gives many errors.
> Can someone please tell me why there are errors in project hive ?  I 
> followed all steps correctly from hive wiki.
> Regards,


View raw message