hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johan Oskarsson (JIRA)" <>
Subject [jira] Commented: (HIVE-116) Test run fails to complete
Date Fri, 05 Dec 2008 18:00:44 GMT


Johan Oskarsson commented on HIVE-116:

Just having test depend on jar in build-common.xml doesn't work for me. Tried both running
"ant test" straight in the project root and in the metastore dir.
For example, doing the latter gives errors such as:
     [echo] Compiling: 
    [javac] Compiling 38 source files to /home/johan/workspace/hive-116/build/metastore/classes
    [javac] /home/johan/workspace/hive-116/metastore/src/java/org/apache/hadoop/hive/metastore/
package org.apache.hadoop.hive.conf does not exist
    [javac] import org.apache.hadoop.hive.conf.HiveConf;          

etc etc....
I assume they're not run in the right order?

> Test run fails to complete
> --------------------------
>                 Key: HIVE-116
>                 URL:
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Testing Infrastructure
>    Affects Versions: 0.19.0
>         Environment: 32bit Ubuntu Hardy, Java6, Ant 1.7
>            Reporter: Johan Oskarsson
>            Assignee: Johan Oskarsson
>            Priority: Critical
>             Fix For: 0.19.0
>         Attachments: HIVE-116.patch, test.log
> When running either "ant deploy test" or just "ant test" from a newly checked out hive
trunk (with HIVE-90 applied) the test suite fails to complete. Not because tests cases fail
but because classes can't be found. I assume it has something to do with the order the different
modules are compiled in before the tests are run.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message