hive-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yh...@apache.org
Subject svn commit: r1529830 - in /hive/trunk: eclipse-templates/.classpath shims/ivy.xml
Date Mon, 07 Oct 2013 13:00:36 GMT
Author: yhuai
Date: Mon Oct  7 13:00:36 2013
New Revision: 1529830

URL: http://svn.apache.org/r1529830
Log:
HIVE-5385 : StringUtils is not in commons codec 1.3 (Kousuke Saruta via Yin Huai)

Modified:
    hive/trunk/eclipse-templates/.classpath
    hive/trunk/shims/ivy.xml

Modified: hive/trunk/eclipse-templates/.classpath
URL: http://svn.apache.org/viewvc/hive/trunk/eclipse-templates/.classpath?rev=1529830&r1=1529829&r2=1529830&view=diff
==============================================================================
--- hive/trunk/eclipse-templates/.classpath (original)
+++ hive/trunk/eclipse-templates/.classpath Mon Oct  7 13:00:36 2013
@@ -20,7 +20,7 @@
   <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
   <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/ant-1.6.5.jar"/>
   <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-cli-1.2.jar"/>
-  <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-codec-1.3.jar"/>
+  <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-codec-1.4.jar"/>
   <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-el-1.0.jar"/>
   <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-httpclient-3.0.1.jar"/>
   <classpathentry kind="lib" path="build/ivy/lib/hadoop0.20.shim/commons-logging-1.1.1.jar"/>

Modified: hive/trunk/shims/ivy.xml
URL: http://svn.apache.org/viewvc/hive/trunk/shims/ivy.xml?rev=1529830&r1=1529829&r2=1529830&view=diff
==============================================================================
--- hive/trunk/shims/ivy.xml (original)
+++ hive/trunk/shims/ivy.xml Mon Oct  7 13:00:36 2013
@@ -125,6 +125,15 @@
       <include type="jar"/>
       <exclude org="commons-daemon" module="commons-daemon"/><!--bad POM-->
       <exclude org="org.apache.commons" module="commons-daemon"/><!--bad POM-->
+      <exclude org="commons-codec" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
+      <exclude org="org.apache.commons" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
+    </dependency>
+
+    <dependency org="commons-codec" name="commons-codec" 
+                rev="${commons-codec.version}" conf="hadoop0.20.shim->default">
+      <include type="jar"/>
+      <exclude org="commons-daemon" module="commons-daemon"/><!--bad POM-->
+      <exclude org="org.apache.commons" module="commons-daemon"/><!--bad POM-->
     </dependency>
 
     <dependency org="org.apache.hadoop" name="hadoop-core"
@@ -133,6 +142,8 @@
       <include type="jar"/>
       <exclude org="commons-daemon" module="commons-daemon"/><!--bad POM-->
       <exclude org="org.apache.commons" module="commons-daemon"/><!--bad POM-->
+      <exclude org="commons-codec" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
+      <exclude org="org.apache.commons" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
     </dependency>
     <dependency org="org.apache.hadoop" name="hadoop-tools"
                 rev="${hadoop-0.20.version}"
@@ -140,6 +151,8 @@
       <include type="jar"/>
       <exclude org="commons-daemon" module="commons-daemon"/><!--bad POM-->
       <exclude org="org.apache.commons" module="commons-daemon"/><!--bad POM-->
+      <exclude org="commons-codec" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
+      <exclude org="org.apache.commons" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
     </dependency>
     <dependency org="org.apache.hadoop" name="hadoop-test"
                 rev="${hadoop-0.20.version}"
@@ -147,6 +160,8 @@
       <include type="jar"/>
       <exclude org="commons-daemon" module="commons-daemon"/><!--bad POM-->
       <exclude org="org.apache.commons" module="commons-daemon"/><!--bad POM-->
+      <exclude org="commons-codec" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
+      <exclude org="org.apache.commons" module="commons-codec" /><!--ignore commons-codec
1.3 to use 1.4-->
     </dependency>
 
     <!-- Hadoop 0.20S (or 1.0.0) shim dependencies. Used for building 0.20S shims. -->



Mime
View raw message