helix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zhen Zhang <zzh...@linkedin.com>
Subject RE: Bucketized resources not working in Helix 0.6.4
Date Mon, 23 Feb 2015 18:35:08 GMT
Hi Varun,

HelixAdmin#addResource was initially used for adding an empty resource only, followed by HelixAdmin#rebalance,
which bucketize the ideal state, so the bucketize logic is missing from addResource. We should
definitely fix this. We are also considering merging addResource and rebalance, since separating
them are confusing. For now you may use setResourceIdealState as a workaround.


From: Varun Sharma [varun@pinterest.com]
Sent: Monday, February 23, 2015 10:20 AM
To: user@helix.apache.org
Subject: Re: Bucketized resources not working in Helix 0.6.4

Thanks, Zhen.

What about just calling addResource with an idealState with the bucket size - is that expected
to not work on its own ?


On Mon, Feb 23, 2015 at 10:18 AM, Zhen Zhang <zzhang@linkedin.com<mailto:zzhang@linkedin.com>>
Hi Varun,

Did you do the following?
HelixAdmin#addResource() // set bucket size
HelixAdmin#setResourceIdealState() // no bucket size

When you set the ideal state, you still need set the bucket size in the ideal state. This
value will be used to bucketize the ideal state.


From: Varun Sharma [varun@pinterest.com<mailto:varun@pinterest.com>]
Sent: Monday, February 23, 2015 1:51 AM
To: user@helix.apache.org<mailto:user@helix.apache.org>
Subject: Bucketized resources not working in Helix 0.6.4


I am trying to bucketize a resource on Helix 0.6.4 - however, am unable to do so. I am setting
the bucketSize in the idealState and using addResource() and setResourceIdealState and it
ends up complaining that ZK size of 1M has been exceeded.

I also tried using the addResource() api which creates an empty ideal state with a valid bucket
size. However, when I tried to set the ideal state on that bucket (this ideal state did not
have the bucket size set), it failed as well.

Whats the right way to get bucketizing to work ?

Thanks !

View raw message