helix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zhen Zhang <zzh...@linkedin.com>
Subject RE: Bucketized resources not working in Helix 0.6.4
Date Mon, 23 Feb 2015 18:18:09 GMT
Hi Varun, 

Did you do the following?
HelixAdmin#addResource() // set bucket size
HelixAdmin#setResourceIdealState() // no bucket size

When you set the ideal state, you still need set the bucket size in the ideal state. This
value will be used to bucketize the ideal state. 

Thanks,
Jason

________________________________________
From: Varun Sharma [varun@pinterest.com]
Sent: Monday, February 23, 2015 1:51 AM
To: user@helix.apache.org
Subject: Bucketized resources not working in Helix 0.6.4

Hi,

I am trying to bucketize a resource on Helix 0.6.4 - however, am unable to do so. I am setting
the bucketSize in the idealState and using addResource() and setResourceIdealState and it
ends up complaining that ZK size of 1M has been exceeded.

I also tried using the addResource() api which creates an empty ideal state with a valid bucket
size. However, when I tried to set the ideal state on that bucket (this ideal state did not
have the bucket size set), it failed as well.

Whats the right way to get bucketizing to work ?

Thanks !
Varun
Mime
View raw message