helix-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HELIX-329) HelixAutoController isn't a very clear name, consider renaming
Date Fri, 22 Aug 2014 00:48:11 GMT

    [ https://issues.apache.org/jira/browse/HELIX-329?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14106258#comment-14106258
] 

Hudson commented on HELIX-329:
------------------------------

UNSTABLE: Integrated in helix #1285 (See [https://builds.apache.org/job/helix/1285/])
[HELIX-329] HelixAutoController isn't a very clear name, consider renaming (zzhang: rev 0746d07872cf3fb07ec2995adff7980e11e2a8b3)
* helix-core/src/test/java/org/apache/helix/participant/TestDistControllerStateModelFactory.java
* helix-admin-webapp/src/test/java/org/apache/helix/webapp/TestHelixAdminScenariosRest.java
* helix-core/src/test/java/org/apache/helix/participant/TestMultiClusterControllerStateModel.java
* helix-core/src/test/java/org/apache/helix/manager/zk/TestZkHelixMultiClusterController.java
* helix-core/src/test/java/org/apache/helix/integration/TestAddNodeAfterControllerStart.java
* helix-core/src/main/java/org/apache/helix/HelixConnection.java
* helix-core/src/main/java/org/apache/helix/controller/HelixControllerMain.java
* helix-core/src/test/java/org/apache/helix/participant/TestDistControllerStateModel.java
* helix-core/src/test/java/org/apache/helix/integration/TestAddClusterV2.java
* helix-core/src/main/java/org/apache/helix/HelixManager.java
* helix-core/src/main/java/org/apache/helix/participant/DistClusterControllerStateModelFactory.java
* helix-core/src/main/java/org/apache/helix/manager/zk/ZkHelixConnection.java
* helix-core/src/test/java/org/apache/helix/integration/TestMultiClusterController.java
* helix-core/src/main/java/org/apache/helix/participant/MultiClusterControllerStateModelFactory.java
* helix-core/src/test/java/org/apache/helix/integration/manager/TestConsecutiveZkSessionExpiry.java
* helix-core/src/test/java/org/apache/helix/manager/zk/TestZkHelixAutoController.java
* helix-core/src/main/java/org/apache/helix/manager/zk/ZKHelixManager.java
* helix-core/src/main/java/org/apache/helix/participant/MultiClusterControllerStateModel.java
* helix-core/src/test/java/org/apache/helix/integration/TestReelectedPipelineCorrectness.java
* helix-core/src/main/java/org/apache/helix/participant/DistClusterControllerStateModel.java
* helix-core/src/test/java/org/apache/helix/participant/TestMultiClusterControllerStateModelFactory.java
* helix-core/src/test/java/org/apache/helix/integration/TestDistributedCMMain.java
* helix-core/src/test/java/org/apache/helix/manager/zk/MockMultiClusterController.java
* helix-core/src/test/java/org/apache/helix/integration/manager/TestHelixMultiClusterController.java
* helix-core/src/test/java/org/apache/helix/monitoring/TestClusterStatusMonitorLifecycle.java


> HelixAutoController isn't a very clear name, consider renaming
> --------------------------------------------------------------
>
>                 Key: HELIX-329
>                 URL: https://issues.apache.org/jira/browse/HELIX-329
>             Project: Apache Helix
>          Issue Type: Sub-task
>            Reporter: Kanak Biscuitwala
>            Assignee: Zhen Zhang
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> In 0.7.0 Helix introduced new role classes, of which HelixAutoController is one, representing
CONTROLLER_PARTICIPANT. This name doesn't really describe what the role represents, so it
might be best to rename.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message