hdt-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Evert Lammerts (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDT-15) Runtime dependencies not satisfied
Date Sat, 16 Mar 2013 22:30:13 GMT

    [ https://issues.apache.org/jira/browse/HDT-15?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13604437#comment-13604437
] 

Evert Lammerts commented on HDT-15:
-----------------------------------

We might need to include all dependencies of the release we're talking to. In the current
code we assume 1.0.4. The question is whether (and how) we will allow selection of a Hadoop
release during runtime, or if people need to select their version beforehand. The latter would
imply a separate HDT branch for each Hadoop release, I guess... I can also see how we could
support multiple versions in one release, allowing to select the release during runtime. It
would make the codebase more complex though.
                
> Runtime dependencies not satisfied
> ----------------------------------
>
>                 Key: HDT-15
>                 URL: https://issues.apache.org/jira/browse/HDT-15
>             Project: Hadoop Development Tools
>          Issue Type: Bug
>            Reporter: Bob Kerns
>
> When trying to open a cluster, it gets the error below. I presume there are more necessary
jars we're not providing as well.
> java.lang.NoClassDefFoundError: org/codehaus/jackson/map/JsonMappingException
> 	at org.apache.hdt.core.cluster.HadoopCluster.getJobClient(HadoopCluster.java:484)
> 	at org.apache.hdt.core.cluster.HadoopCluster$LocationStatusUpdater.run(HadoopCluster.java:107)
> 	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
> Caused by: java.lang.ClassNotFoundException: org.codehaus.jackson.map.JsonMappingException
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
> 	at java.lang.ClassLoader.loadClass(Unknown Source)
> 	... 3 more

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message