hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Backward compatibility report
Date Tue, 07 Jun 2016 10:24:46 GMT
On 6 June 2016 at 16:09, Ponomarenko Andrey <andrewponomarenko@yandex.ru> wrote:
> Hello,
>
> I've prepared backward compatibility reports for HttpClient and HttpCore libraries:
>
> http://abi-laboratory.pro/java/tracker/timeline/httpclient/
> http://abi-laboratory.pro/java/tracker/timeline/httpcore/
>
> I hope they will help users, maintainers and developers to maintain backward compatibility.
The reports are updated daily by the japi-compliance-checker and japi-tracker tools: https://github.com/lvc/japi-compliance-checker
>
> Please let me know if there are some false positives in the report.

It does not make sense to check compatibility between 4.x and 5.x

The 5.0 series deliberately breaks compatibility.
So it uses a different package name and different Maven coordinates.
This allows the jars to co-exist safely on the classpath.

Note: if either the package name is changed, or the Maven coord (GA)
is changed (but not both) then that is an error.

> Thank you.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
> For additional commands, e-mail: httpclient-users-help@hc.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message