hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Code with 4.x deprecations already removed?
Date Mon, 14 Sep 2015 07:45:07 GMT
On Sat, 2015-09-12 at 10:25 -0600, Shawn Heisey wrote:
> Does the trunk code for client/mime/core already have the 4.x
> deprecations removed?
> 

Yes, it does. 

> I'd like to work on bringing Solr into the modern age where
> httpcomponents is concerned (SOLR-5604 in the Apache Jira), but unless I
> can get my IDE to tell me what's still using deprecated code, that's
> fairly difficult.  So I'm hoping I can build 5.0 snapshot jars, replace
> the 4.x jars in my local source code, and see errors everywhere we are
> using deprecated HC interfaces.  This would also help me move some of
> the things currently defined on the HttpClient object to lower levels,
> like the socket timeout that has been giving me fits recently.
> 
> I do have the option of telling the IDE to mark ALL deprecations as
> errors, but that highlights a lot more than HC.  I will go that route if
> I need to.
> 

You should not be using 5.0 unless you intent to participate in
development of HttpClient. The trunk is currently unstable and I have no
idea how long it may take for it to get stable enough for a GA release.
Please use 4.5.x branch for now. It will still have all deprecated
functionality intact.

Cheers

Oleg


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message