hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Magnus Landrø <stefan.lan...@gmail.com>
Subject Re: Async problem with GET
Date Mon, 31 Aug 2015 15:58:43 GMT


Sendt fra min iPhone

> Den 31. aug. 2015 kl. 09.48 skrev Graeme Wallace <graeme.wallace@farecompare.com>:
> 
> I'm running into a strange problem using async http components. I have a
> site that i'm using GET to pull information back from on a fairly regular
> basis - maybe a query every minute or so.
> 
> After about 8 hours - the site starts sending back its homepage instead of
> the information i'm requesting the URL. The only way to fix it is to
> restart the application i'm running - which makes no sense.

Have you performed a heap dump to see why it crashes? The issue should be fairly easy to reproduce
in a few minutes in a test env

I recommend using eclipse mat to find root cause. 



> 
> I'm kind of at a loss on how to debug this one because it takes so long for
> the problem to show up, and that its fixed by restarting the application.
> this would suggest its something down in the guts of async http components
> - but i've no idea where.
> 
> Any suggestions ?
> 
> 
> -- 
> Graeme Wallace
> CTO
> FareCompare.com
> O: 972 588 1414
> M: 214 681 9018

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message