hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Async problem with GET
Date Mon, 31 Aug 2015 16:06:11 GMT
On Mon, 2015-08-31 at 18:01 +0200, Stefan Magnus Landrø wrote:
> 
> Sendt fra min iPhone
> 
> > Den 31. aug. 2015 kl. 11.07 skrev Oleg Kalnichevski <olegk@apache.org>:
> > 
> >> On Mon, 2015-08-31 at 08:48 +0100, Graeme Wallace wrote:
> >> I'm running into a strange problem using async http components. I have a
> >> site that i'm using GET to pull information back from on a fairly regular
> >> basis - maybe a query every minute or so.
> >> 
> >> After about 8 hours - the site starts sending back its homepage instead of
> >> the information i'm requesting the URL. The only way to fix it is to
> >> restart the application i'm running - which makes no sense.
> >> 
> >> I'm kind of at a loss on how to debug this one because it takes so long for
> >> the problem to show up, and that its fixed by restarting the application.
> >> this would suggest its something down in the guts of async http components
> >> - but i've no idea where.
> >> 
> >> Any suggestions ?
> > 
> > Graeme,
> > 
> > How could this possibly be something down in the guts of HC? Alien
> > conspiracy? Russian spies?
> > 
> > Have you tried resetting the session (by wiping out the cookies) instead
> > of restarting the app?
> 
> Do you think the session is accumulating more and more data? If so, why not log out of
app or disable cookie support client side (or is the resource login protected?)
> 

That is my theory. I cannot think of anything that could be possibly
causing this issue on the client side.

Oleg



---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message