hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Magnus Landrø <stefan.lan...@gmail.com>
Subject Re: There are known problems of running HttpClient in a web application?
Date Thu, 28 May 2015 22:17:19 GMT
have you set up log bridging from commons logging to log4j2?

2015-05-29 0:07 GMT+02:00 Emiliano Carlesi <emiliano.carlesi@itattitude.com>
:

> I'm debugging my web app using Eclipse Luna and Apache Tomcat 7.0.59.
>
>
>
> Emiliano Carlesi
>
> Email: emiliano.carlesi@itattitude.com
> Lync: emiliano.carlesi@itattitude.com
> Mobile: +39 3487837153
> Phone: +39 0650939115
>
>
>
> -----Original Message-----
> From: Stefan Magnus Landrø [mailto:stefan.landro@gmail.com]
> Sent: Friday, May 29, 2015 12:00 AM
> To: HttpClient User Discussion
> Subject: Re: There are known problems of running HttpClient in a web
> application?
>
> What server are you running on?
>
> 2015-05-28 23:58 GMT+02:00 Stefan Magnus Landrø <stefan.landro@gmail.com>:
>
> > What logging framework are you using?
> >
> > 2015-05-28 23:43 GMT+02:00 Emiliano Carlesi <
> > emiliano.carlesi@itattitude.com>:
> >
> >> Hi to all,
> >> I have a problem I can't understand related to the execution of
> >> HttpClient 4 within a web application running in Tomcat + Struts2.
> >>
> >> I create an HTTP client for a specific site that uses basic
> >> authentication over HTTPS.
> >> While execute my client from a console application,  it works properly.
> >> When I try to use the client from within the web application I always
> >> get an HTTP 301 result code from the web server.
> >>
> >> I have no access to the server logs.
> >>
> >> I try to enable the trace using these  instruction:
> >>
> >>
> >> System.setProperty("org.apache.commons.logging.Log","org.apache.commo
> >> ns.logging.impl.SimpleLog");
> >> System.setProperty("org.apache.commons.logging.simplelog.showdatetime
> >> ",
> >> "true");
> >> System.setProperty("org.apache.commons.logging.simplelog.log.org.apac
> >> he.http.wire",
> >> "DEBUG");
> >> System.setProperty("org.apache.commons.logging.simplelog.log.org.apac
> >> he.http.impl.conn",
> >> "DEBUG");
> >> System.setProperty("org.apache.commons.logging.simplelog.log.org.apac
> >> he.http.impl.client",
> >> "DEBUG");
> >> System.setProperty("org.apache.commons.logging.simplelog.log.org.apac
> >> he.http.client",
> >> "DEBUG");
> >> System.setProperty("org.apache.commons.logging.simplelog.log.org.apac
> >> he.http",
> >> "DEBUG");
> >>
> >> The trace work when I invoke the client from within the console
> >> application, instead nothing is logged when the client is invoked
> >> from within the web application.
> >>
> >> I try to use fiddler to see what travel on the wire but there are
> >> problem with the HTTPS.
> >>
> >> There is some known issue with this scenario?
> >>
> >> Thanks
> >>
> >> Ciao
> >>
> >> Emiliano Carlesi
> >>
> >> Email: emiliano.carlesi@itattitude.com
> >> Lync: emiliano.carlesi@itattitude.com
> >> Mobile: +39 3487837153
> >> Phone: +39 0650939115
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
> >> For additional commands, e-mail: httpclient-users-help@hc.apache.org
> >>
> >>
> >
> >
> > --
> > BEKK Open
> > http://open.bekk.no
> >
> > TesTcl - a unit test framework for iRules http://testcl.com
> >
>
>
>
> --
> BEKK Open
> http://open.bekk.no
>
> TesTcl - a unit test framework for iRules http://testcl.com
>



-- 
BEKK Open
http://open.bekk.no

TesTcl - a unit test framework for iRules
http://testcl.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message