hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vasudevan Comandur <vcoman...@gmail.com>
Subject Parsing of Set-Cookie in HTTPClient 3.1 Version
Date Thu, 27 Sep 2012 19:49:09 GMT
Hi,

  I am using HTMLUnit 2.6 which uses the HTTPClient 3.1 jar file. The
cookie value returned to HTMLUnit has corrupted values.
  Trying to figure why the value of the Cookie string has changed.

  I was analysing the data transfer thru a web proxy tool and this is what
I found.

  Original Set-Cookie header from Host


xploreCookies={"standardsLicenseId":"0","openUrl":"NA","enterpriseLicenseId":"0","isIp":"false","desktopReportingUrl":"null","openUrlImgLoc":"NA","products":"IEL|VDE|","contactName":"NA","isChargebackUser":"false","contactEmail":"NA","oldSessionKey":"KFWG946KOwzR11w2m1Nxxx2B9vUv3g87Pm3*6ZpsGyUs14HLuWsDK7Bx2FIQx3Dx3D-18x2dv10fgohpBt3Xs0XqhOfBNgx3Dx3D1t5obVnf1D9x2BkhlHMXhZOQx3Dx3D-XrL4FnIlW2OPkqtVJq0LkQx3Dx3D-tujOLwhFqtX7Pa7HGqmCXQx3Dx3D","userIds":"80882","instImage":"","isInst":"true","isDelegatedAdmin":"false","isMember":"false","customerSurvey":"NA","smallBusinessLicenseId":"0","openUrlTxt":"NA"};
domain=.ieee.org; path=/

   The values that were sent out on the wire by HTTPClient due to
redirection is

---------------------------------------------------------------------------------------------------------------

xploreCookies={"standardsLicenseId":"0"; "openUrl":"NA"=;
"enterpriseLicenseId":"0"=; "isIp":"false"=; "desktopReportingUrl":"null"=;
"openUrlImgLoc":"NA"=; "products":"IEL|VDE|"=; "contactName":"NA"=;
"isChargebackUser":"false"=; "contactEmail":"NA"=;
"oldSessionKey":"KFWG946KOwzR11w2m1Nxxx2B9vUv3g87Pm3*6ZpsGyUs14HLuWsDK7Bx2FIQx3Dx3D-18x2dv10fgohpBt3Xs0XqhOfBNgx3Dx3D1t5obVnf1D9x2BkhlHMXhZOQx3Dx3D-XrL4FnIlW2OPkqtVJq0LkQx3Dx3D-tujOLwhFqtX7Pa7HGqmCXQx3Dx3D"=;
"userIds":"80882"=; "instImage":""=; "isInst":"true"=;
"isDelegatedAdmin":"false"=; "isMember":"false"=;  "customerSurvey":"NA"=;
"smallBusinessLicenseId":"0"=; "openUrlTxt":"NA"}=

  Can someone throw light on why the cookie value has been changed?.

   Any pointers and help required to solve this problem is appreciated.

   Looking forward to the reply.

Thanks & Regards
 Vasu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message