hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: commons httpclient backwards compatibility between version 2 and 3.1
Date Thu, 04 Nov 2010 20:48:58 GMT
On Thu, 2010-11-04 at 10:42 +0000, Craig Blackman wrote:
> Hi,
> 
> Is release 3.1 backwards compatible with release 2.0 please?
> I.e. a release 2 jar could be upgraded to release 3.1 and code that used the
> release 2 jar would still function correctly?
> 
> Apologies if this is a mis-directed question but I'm struggling to find any
> reference regarding backwards compatibility.
> 
> All responses appreciated.
> 
> Kind regards
> 
> Craig Blackman

Craig

All major releases of HttpClient are not backward compatible. Please
also note that versions 2.0 and 3.1 are not longer maintained and
supported. 

Oleg



---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message