hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Krugler <kkrugler_li...@transpac.com>
Subject Re: defaulthttpclient - connected ?
Date Tue, 04 May 2010 20:19:42 GMT
This sounds like an issue with the session management of the server,  
not HttpClient.

If so, then all you can do is try to ping a URL and check the response  
for a 403 (if the server is well behaved). Some servers will just  
silently redirect you to a login page, so you'd need to watch for a  
temp redirect response.

-- Ken

On May 4, 2010, at 12:47pm, Langston, James wrote:

> Hi all,
>
> Is there a way to check that I'm still connected w/  
> defaulthttpclient ?
> Essentially,
> I'm logged into a server and if the login session gets timed out or  
> not,
> I just quickly
> want to check, but I don't see any easy methods to utilize ...
>
> Thanks,
>
> Jim
>
> ////////////////
>
> Jim Langston
> Technical Consultant
> james.langston@compuware.com
>
>
>
> The contents of this e-mail are intended for the named addressee  
> only. It contains information that may be confidential. Unless you  
> are the named addressee or an authorized designee, you may not copy  
> or use it, or disclose it to anyone else. If you received it in  
> error please notify us immediately and then destroy it.
>

--------------------------------------------
Ken Krugler
+1 530-210-6378
http://bixolabs.com
e l a s t i c   w e b   m i n i n g





---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message