hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaiser Sose <carlo.bertucc...@live.it>
Subject Re: Internal connection working only behind proxy????
Date Mon, 22 Feb 2010 13:57:25 GMT


Sam Crawford wrote:
> 
> Looks like your server is sending back invalid HTTP headers:
> 
> DEBUG main org.apache.http.wire - << ": [EOL]"
> 
> I'd suspect an Apache misconfiguration...
> 
> Thanks,
> 
> Sam
> 

Hi Sam,
debugging too I noticed an empty header arriving who cause the execute to
crash during the header parsing. What I don't understand are the following

1 - Why does Firefox/IE works fine even if the server send back an empty
header?
2 - I've tried to parse headers "live" with Firefox addons Live HTTPHeaders
and that's what it sends back, why can't I see this empty header?

http://src-seo.pgol.com/seo/search?ln=1&pag=1&ord=a&tkc=20&cht=2

GET /seo/search?ln=1&pag=1&ord=a&tkc=20&cht=2 HTTP/1.1
Host: my.host.net
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.2)
Gecko/20100115 Firefox/3.6
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: it-it,it;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip, deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Connection: keep-alive

HTTP/1.1 200 OK
Date: Mon, 22 Feb 2010 13:40:57 GMT
Server: Apache
Keep-Alive: timeout=1
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/xml

Best Regards
-- 
View this message in context: http://old.nabble.com/Internal-connection-working-only-behind-proxy-----tp27655291p27687522.html
Sent from the HttpClient-User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message